url rewriting in global.asax is not working on iis

Ikramshams
 
on May 13, 2016 06:36 AM
5748 Views

I have written url rewriting in global.asax. it is working fine Server and  on my system when i open it through visual studio. But it is not working when i upload it on IIS(windows 7). It gives me error 

HTTP Error 404.0 - Not Found. How i will solve this issue. please suggest me.

Download FREE API for Word, Excel and PDF in ASP.Net: Download
Andrea
 
on May 13, 2016 06:36 AM
Hi @Ikramshams,
Please try the following

URL Rewriting not working in IIS 6

It might help you.

Cheers Andrea.
Ikramshams
 
on May 13, 2016 07:36 AM
on May 13, 2016 07:37 AM

Thanks for your quick response. Here in my case, I have not created a virtual directory. I have created a website in Sites in IIS. i am using windows 7. How i will add aspnet_isapi.dll in Configuration.

Ikramshams
 
on May 13, 2016 08:28 AM

in windows7,in IIS, if i am creating a virtual directory in my websites in sites then i an not finding properties on right click of virtual directory. so i am not following the below steps. Perhaps, the below steps are for windows server 2003. what are steps for adding aspnet_isapi.dll in Configuration in windows7.

  1. In IIS, right click on the Virtual Directory, select Properties.
  2. Under the Directory tab, click the Configuration... button.
  3. Under the Mappings tab, under the Wildcard application maps (order of implementation): click the Insert... button.
  4. Browse and select C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll, leave Verify that the file exists unchecked.
  5. Move Up aspnet_isapi.dll to the top of the list.
  6. Click Ok, Ok, and try it. Try recycling the application pool if you don't see it work.

We had a situation where the .Net Routing was working on our development PCs but not on the test and production server with IIS 6 and Windows 2003. This fixed our problem.