[Solved] ASP.Net AjaxToolKit HtmlEditorExtender not working while changing from Visual Studio 2010 to 2015

ilanocf
 
on Dec 04, 2021 03:20 PM
920 Views

Hey guys,

I'm having problems with Visual Studio 2015 regarding the HtmlEditorExtender that I put on the page but the control bar doesn't appear.

I'm leaving the aspx body so you can see if I'm doing something wrong. The funny thing is that on other pages where this component already existed (when it was made in the previous version) it appears ok but if I take it out and put it back in (in the current version) or just add a new HtmlEditorExtender control to the developed page in VS 2010 the bar with the controls simply does not appear.

I've already changed the ScriptManager in MasterPage but it didn't do any good. I also created a new web.config and it didn't do any good either. Now, if I create a new page, completely from scratch, and add the component then it works. Does anyone have any idea how to solve this?

theoretically dll remains the same because I just uninstalled VS2010, installed VS2015 and called the project folder which was already 2010.

For me, theoretically, the dlls are the same as in 2010. Or am I wrong? Because I didn't change any of these dlls.

Grateful,

Ilano

Download FREE API for Word, Excel and PDF in ASP.Net: Download
dharmendr
 
on Dec 09, 2021 07:01 AM
ilanocf says:
For me, theoretically, the dlls are the same as in 2010. Or am I wrong? Because I didn't change any of these dlls.

Yes the dlls are the same as in 2010 or 2015.

Can you please check the browser console if any error?

Also let me know other AjaxToolKit controls are working fine or not.

Also try the below steps.

1. Delete the Microsoft.ScriptManager.MsAjax.dll from References Folder (If you couldn't find then select Show All Files in Solution Explorer) if exists.

2. Manually browse and locate the bin folder inside your project folder. Delete the Microsoft.ScriptManager.MsAjax.dll from bin folder if exists.

3. Try to rebuild your solution and check.