How to set innodb_log_file_size in MySql database

ISGSurya
 
on Jan 18, 2016 02:30 AM
6617 Views

Hello,

         While saving excel file in to MYSQL db from vb.net iam getting error as The size of BLOB/TEXT data inserted in one transaction is greater than 10% of redo log size. Increase the redo log size using innodb_log_file_size, how to resolve this i tried to increase innodb_file_size in mysql.ini but its not allowing me to save saying access is denied.

Download FREE API for Word, Excel and PDF in ASP.Net: Download
Shashikant
 
on Jan 18, 2016 02:33 AM

Hi,

Please follow below steps

  • Have you restarted mysql service after changing my.ini?
  • Run query SHOW GLOBAL VARIABLES LIKE 'max_allowed_packet' and see the value. It should be 500MB (Equal bytes)
  • If the above query does not return 500M, then try running SET GLOBAL max_allowed_packet = 500 * 1024 * 1024. Then repeat step 2.
  • If value is shown as 500 M repeat your file upload.

Or

To resolve your issue you have to increase the value of the innodb_log_file_size option in your my.ini below the [mysqld] section. Its default value is 48M. Setting it to

innodb_log_file_size=256M

I hope this will help you out.

 

ISGSurya
 
on Jan 18, 2016 02:41 AM

Trying to change log file size in my.ini for innodb_log_file_size after change and try to close ini file its asking me to save, if i hit save it shows error as access denied. how to resolve it i think admin has user rights to change it. what u say?

Shashikant
 
on Jan 18, 2016 02:57 AM

Yes